СоздатьСписокЗначенийИнтерактивноСоздаваемыхКонтактов (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Создать список значений интерактивно создаваемых контактов. Получает массив описания возможных контактов и формирует из него список значений

// Получает массив описания возможных контактов и формирует из него список значений
// контактов, которые можно создать интерактивно.
//
// Возвращаемое значение:
//  СписокЗначений - список значений, который содержит контакты, которые можно создать интерактивно.
//
Функция СоздатьСписокЗначенийИнтерактивноСоздаваемыхКонтактов() Экспорт
	
	МассивОписанияВозможныхТиповКонтактов = ВзаимодействияКлиентСервер.ОписанияКонтактов();
	СписокКонтактовКоторыеМожноСоздать = Новый СписокЗначений;
	
	Для каждого ЭлементМассива Из МассивОписанияВозможныхТиповКонтактов Цикл
		
		Если ЭлементМассива.ВозможностьИнтерактивногоСоздания И ПравоДоступа("Добавление", Метаданные.Справочники[ЭлементМассива.Имя])Тогда
			
			СписокКонтактовКоторыеМожноСоздать.Добавить(ЭлементМассива.Имя, ЭлементМассива.Представление);
			
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат СписокКонтактовКоторыеМожноСоздать;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СоздатьКонтакт (БСП)

ПолучитьКонтактыПоПредмету (БСП)

ДеревоЗначений вывод на управляемую форму

ЗаполнитьНайденныеКонтакты (БСП)

СписокДоступныхПоисков (БСП)

СоздатьКонтактНестандартнаяФорма (БСП)

СкопироватьСписокЗначений (БСП)

Интерактивный отбор дерева значений

ДобавитьПослеВыбораРежимаСоздания (БСП)

TurboConf - расширение Конфигуратора 1С