ТемаПоТекстуСообщения (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Тема по тексту сообщения. Формирует тему по тексту сообщения на основании первых трех слов.

// Формирует тему по тексту сообщения на основании первых трех слов.
//
// Параметры:
//  ТекстСообщения  - Строка - текст сообщения, на основании которого формируется тема.
//
// Возвращаемое значение:
//   Строка   - сформированная тема сообщения.
//
Функция ТемаПоТекстуСообщения(ТекстСообщения) Экспорт

	МассивСтрок = СтрРазделить(ТекстСообщения," ", Ложь);
	Тема = "";
	Для Инд = 0 По МассивСтрок.Количество() - 1 Цикл
		Если Инд > 2 Тогда
			Прервать;
		КонецЕсли;
		Тема = Тема + МассивСтрок[Инд] + " ";
	КонецЦикла;
	
	Возврат Лев(Тема, СтрДлина(Тема) - 1);

КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ТемаВзаимодействия (БСП)

ПараметрыИзТекстаСообщения (БСП)

СформироватьСообщениеБлокировки (БСП)

ШаблонТемы (БСП)

Проверить (БСП)

ТекстДляАдминистратора (БСП)

ПараметрыШаблона (БСП)

СообщениеДанныеЕщеОбновляются (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз