ТипВзаимодействияПоИмениКоманды (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Тип взаимодействия по имени команды.

Функция ТипВзаимодействияПоИмениКоманды(ИмяКоманды, ТолькоПочта) Экспорт
	
	НайденнаяПозиция = СтрНайти(ИмяКоманды, "_");
	Если НайденнаяПозиция = 0 Тогда
		Возврат "Все";
	КонецЕсли;
	
	СтрокаТипВзаимодействия = Прав(ИмяКоманды, СтрДлина(ИмяКоманды) - НайденнаяПозиция);
	Если СписокОтборовПоТипуВзаимодействий(ТолькоПочта).НайтиПоЗначению(СтрокаТипВзаимодействия) = Неопределено Тогда
		Возврат "Все";
	КонецЕсли;
	
	Возврат СтрокаТипВзаимодействия;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

НомерКартинкиПоВзаимодействию (БСП)

ОписаниеКоманды (БСП)

ЗаполнитьПодменюПоТипуВзаимодействия (БСП)

ОбработатьПодменюОтборПоТипуВзаимодействий (БСП)

СписокОтборовПоТипуВзаимодействий (БСП)

ПриИзмененииОтбораТипВзаимодействий (БСП)

ТипКомандыОткрытиеФормы (БСП)

TurboConf - расширение Конфигуратора 1С