УстановитьЗаголовокФормыЭлектронногоПисьма (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Установить заголовок формы электронного письма. Устанавливает заголовок формы электронного письма.

// Устанавливает заголовок формы электронного письма.
//
// Параметры:
//  Форма - ФормаКлиентскогоПриложения - форма для которой выполняется процедура.
//
Процедура УстановитьЗаголовокФормыЭлектронногоПисьма(Форма) Экспорт

	ОбъектПисьмо = Форма.Объект;
	Если НЕ ОбъектПисьмо.Ссылка.Пустая() Тогда
		Форма.Автозаголовок = Ложь;
		ЗаголовокФормы = ?(ПустаяСтрока(ОбъектПисьмо.Тема), НСтр("ru = 'Письмо без темы'"), ОбъектПисьмо.Тема);
		ЗаголовокФормы = ЗаголовокФормы 
		         + ?(ТипЗнч(ОбъектПисьмо.Ссылка) = Тип("ДокументСсылка.ЭлектронноеПисьмоВходящее"), " (Входящее)", " (Исходящее)");
		Форма.Заголовок = ЗаголовокФормы;
	Иначе
		Если ТипЗнч(ОбъектПисьмо.Ссылка) = Тип("ДокументСсылка.ЭлектронноеПисьмоИсходящее") Тогда
			Форма.Автозаголовок = Ложь;
			Форма.Заголовок = НСтр("ru = 'Исходящее письмо (создание)'");
		КонецЕсли;
	КонецЕсли;

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьПапкуЭлектронногоПисьма (БСП)

ОткрытьФормуОтправкиПисьма (БСП)

УстановитьПометкуУдаленияУВложенийПисьма (БСП)

УстановитьПризнакОтправкиУведомления (БСП)

УстановитьДоступностьКомандСпискаЭлектронныхПодписей (БСП)

ПолучитьВложенияЭлектронногоПисьма (БСП)

ЗаписатьВложениеЭлектронногоПисьмаСкопировавВложениеДругогоПисьма (БСП)

УстановитьТекстПисьма (БСП)

ФайлЯвляетсяЭлектроннымПисьмом (БСП)

TurboConf - расширение Конфигуратора 1С