ЗаполнитьПодменюПоТипуВзаимодействия (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Заполнить подменю по типу взаимодействия.

Процедура ЗаполнитьПодменюПоТипуВзаимодействия(ГруппаПодменю, Форма) Экспорт
	
	СписокОтборов = СписокОтборовПоТипуВзаимодействий(Форма.ТолькоПочта);
	Для каждого Отбор Из СписокОтборов Цикл
		
		Значение = Отбор.Значение;
		
		ИмяКоманды = "УстановитьОтборТипВзаимодействия_" + Значение;
		НайденнаяКоманда = Форма.Команды.Найти(ИмяКоманды);
		
		Если НайденнаяКоманда = Неопределено Тогда
			НоваяКоманда = Форма.Команды.Добавить("УстановитьОтборТипВзаимодействия_" + Значение);
			НоваяКоманда.Действие = "Подключаемый_ИзменитьОтборТипВзаимодействия";
		Иначе
			НоваяКоманда = НайденнаяКоманда;
		КонецЕсли;
		
		ЭлементКнопкаПодменю = Форма.Элементы.Добавить("УстановитьОтборТипВзаимодействия_" + ГруппаПодменю.Имя + "_"+ Значение, Тип("КнопкаФормы"), ГруппаПодменю);
		ЭлементКнопкаПодменю.Вид = ВидКнопкиФормы.КнопкаКоманднойПанели;
		ЭлементКнопкаПодменю.ИмяКоманды = НоваяКоманда.Имя;
		ЭлементКнопкаПодменю.Заголовок = Отбор.Представление;
		ЭлементКнопкаПодменю.ТолькоВоВсехДействиях = Истина;
		
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбработатьПодменюОтборПоТипуВзаимодействий (БСП)

ЗаполнитьПодменюСтатус (БСП)

НомерКартинкиПоВзаимодействию (БСП)

СписокОтборовПоТипуВзаимодействий (БСП)

ТипВзаимодействияПоИмениКоманды (БСП)

ПриИзмененииОтбораТипВзаимодействий (БСП)

ЗаполнитьКонтактыМассиваВзаимодействий (БСП)

ЗаполнитьРеквизитыПоУмолчанию (БСП)

ЗаполнитьКонтактыДляВстречи (БСП)

TurboConf - расширение Конфигуратора 1С