ЗаполнитьПодменюСтатус (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Заполнить подменю статус.

Процедура ЗаполнитьПодменюСтатус(ГруппаПодменю, Форма) Экспорт
	
	Если Не ПолучитьФункциональнуюОпцию("ИспользоватьПризнакРассмотрено") Тогда
		Возврат;
	КонецЕсли;
	
	Для каждого Статус Из СписокСтатусов() Цикл
		
		Значение = Статус.Значение;
		
		НоваяКоманда = Форма.Команды.Добавить("УстановитьОтборСтатус_" + Значение);
		НоваяКоманда.Действие = "Подключаемый_ИзменитьОтборСтатус";
		
		ЭлементКнопкаПодменю = Форма.Элементы.Добавить("УстановитьОтборСтатус_" + Значение, Тип("КнопкаФормы"), 
			ГруппаПодменю);
		ЭлементКнопкаПодменю.Вид                   = ВидКнопкиФормы.КнопкаКоманднойПанели;
		ЭлементКнопкаПодменю.ИмяКоманды            = НоваяКоманда.Имя;
		ЭлементКнопкаПодменю.Заголовок             = Статус.Представление;
		ЭлементКнопкаПодменю.ТолькоВоВсехДействиях = Истина;
	
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаполнитьПодменюПоТипуВзаимодействия (БСП)

ЗаполнитьСтатусПодписи (БСП)

ОбработатьПодменюОтборПоТипуВзаимодействий (БСП)

ОткрытьФормуНастроекПодменюПечать (БСП)

СписокСтатусов (БСП)

СтатусДоставки (БСП)

ОтключитьКомандыПечати (БСП)

Проверка заполненности полей объекта и возврат статуса + незаполненных полей

ПроверитьСтатусОбновления (БСП)

TurboConf - расширение Конфигуратора 1С