ЗаполнитьСписокДоступныхДляСозданияДокументов (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Заполнить список доступных для создания документов. Заполняет список доступных для создания взаимодействий.

// Заполняет список доступных для создания взаимодействий.
//
// Параметры:
//  ДокументыДоступныеДляСоздания - СписокЗначений - заполняемый список значений.
//
Процедура ЗаполнитьСписокДоступныхДляСозданияДокументов(ДокументыДоступныеДляСоздания) Экспорт
	
	Для каждого РегистрируемыйДокумент Из Метаданные.ЖурналыДокументов.Взаимодействия.РегистрируемыеДокументы Цикл
		
		Если Не РегистрируемыйДокумент.Имя = "ЭлектронноеПисьмоВходящее" Тогда
			
			ДокументыДоступныеДляСоздания.Добавить(РегистрируемыйДокумент.Имя,РегистрируемыйДокумент.Синоним);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаполнитьСписокВыбораДоступнымиВидамиТранспорта (БСП)

ЗаполнитьСписокШифрования (БСП)

ЗаполнитьСписокПодписей (БСП)

СписокДоступныхТиповПредметов (БСП)

СписокДоступныхПоисков (БСП)

ЗаполнитьСписокПрограмм (БСП)

Обновить список документов - аналог кнопки F5

ДоступныеОтчеты (БСП)

ЗаполнитьСписокВыбораДляРассмотретьПосле (БСП)

TurboConf - расширение Конфигуратора 1С