ЗаполнитьСписокВыбораВремени (БСП)

Автор: 1С
ОбщийМодуль.Взаимодействия
БСП

Заполнить список выбора времени. Процедура заполняет список выбора времени.

// Процедура заполняет список выбора времени.
// Параметры:
//  ПолеВводаФормы  - элемент-владелец списка,
//  Интервал        - интервал, с которым необходимо заполнить список, по умолчанию час.
Процедура ЗаполнитьСписокВыбораВремени(ПолеВводаФормы, Интервал = 3600) Экспорт

	НачалоРабочегоДня      = '00010101000000';
	ОкончаниеРабочегоДня   = '00010101235959';

	СписокВремен = ПолеВводаФормы.СписокВыбора;
	СписокВремен.Очистить();

	ВремяСписка = НачалоРабочегоДня;
	Пока НачалоЧаса(ВремяСписка) <= НачалоЧаса(ОкончаниеРабочегоДня) Цикл
		Если НЕ ЗначениеЗаполнено(ВремяСписка) Тогда
			ПредставлениеВремени = "00:00";
		Иначе
			ПредставлениеВремени = Формат(ВремяСписка,"ДФ=ЧЧ:мм");
		КонецЕсли;

		СписокВремен.Добавить(ВремяСписка, ПредставлениеВремени);

		ВремяСписка = ВремяСписка + Интервал;
	КонецЦикла;

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ЗаполнитьСписокВыбораДляРассмотретьПосле (БСП)

ЗаполнитьСписокВыбораДоступнымиВидамиТранспорта (БСП)

ЗаполнитьСписокШифрования (БСП)

ЗаполнитьСписокПодписей (БСП)

ЗаполнитьДанныеВыбораАвтоподбораПоСтранам (БСП)

ЗаполнитьСписокПрограмм (БСП)

ЗаполнитьСписокДоступныхДляСозданияДокументов (БСП)

ЗаполнитьСписокПрограммДляПоиска (БСП)

ЗагрузитьФайл (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз