УстановитьСвойствоЭлементовГруппы (БСП)

Автор: 1С
ОбщийМодуль.ВзаимодействияКлиентСервер
БСП

Установить свойство элементов группы. Устанавливает значение свойства для всех подчиненных элементов группы.

// Устанавливает значение свойства для всех подчиненных элементов группы.
Процедура УстановитьСвойствоЭлементовГруппы(ГруппаЭлементов, ИмяСвойства, ЗначениеСвойства) Экспорт
	
	Для каждого ПодчиненныйЭлемент Из ГруппаЭлементов.ПодчиненныеЭлементы Цикл
		
		Если ТипЗнч(ПодчиненныйЭлемент) = Тип("ГруппаФормы") Тогда
			
			УстановитьСвойствоЭлементовГруппы(ПодчиненныйЭлемент, ИмяСвойства, ЗначениеСвойства);
			
		Иначе
			
			ПодчиненныйЭлемент[ИмяСвойства] = ЗначениеСвойства;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

СвойстваГруппыЭлементовФормы (БСП)

УстановитьСвойстваГруппыВидаКонтактнойИнформации (БСП)

УстановитьСвойствоЭлементаФормы (БСП)

ОбъектЯвляетсяГруппой (БСП)

ЗаполнитьГруппуИндикатораОшибки (БСП)

СоздатьГруппуЭлементовОтбора (БСП)

ПроверитьОбновитьСоставСвойствГруппы (БСП)

НайтиЭлементыИГруппыОтбора (БСП)

УдалитьЭлементыГруппыОтбораДинамическогоСписка (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз