ЯвляетсяПредметом (БСП)

Автор: 1С
ОбщийМодуль.ВзаимодействияКлиентСервер
БСП

Является предметом. Проверяет, является ли переданная ссылка предметом взаимодействий.

// Проверяет, является ли переданная ссылка предметом взаимодействий.
//
// Параметры:
//  ОбъектСсылка - Ссылка - ссылка, для которой выполняется проверка,
//                          является ли она ссылкой на предмет взаимодействий.
//
// Возвращаемое значение:
//   Булево   - Истина если является, Ложь в обратном случае.
//
Функция ЯвляетсяПредметом(ОбъектСсылка) Экспорт
	
	ПредметыВзаимодействий = ВзаимодействияКлиентСерверСлужебныйПовтИсп.ПредметыВзаимодействий();
	Для каждого Предмет Из ПредметыВзаимодействий Цикл
		Если ТипЗнч(ОбъектСсылка) = Тип(Предмет) Тогда
			Возврат Истина;
		КонецЕсли;
	КонецЦикла;
	Возврат Ложь;	
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ОбъектЯвляетсяПредметомШаблона (БСП)

ПредметыВзаимодействий (БСП)

ОткрытьПредметЗадачи (БСП)

ПредметНачалоВыбора (БСП)

ПолучитьЗначениеПредмета (БСП)

УстановитьПредмет (БСП)

РассчитатьРассмотреноПоПредметам (БСП)

УстановитьПредметДляМассиваВзаимодействий (БСП)

СоздатьВзаимодействиеИлиПредмет (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз