ПриЗаписиУчетнойЗаписиЭлектроннойПочты (БСП)

Автор: 1С
ОбщийМодуль.ВзаимодействияСобытия
БСП

При записи учетной записи электронной почты. Обработчик события при записи учетной записи электронной почты.

// Обработчик события при записи учетной записи электронной почты.
Процедура ПриЗаписиУчетнойЗаписиЭлектроннойПочты(Источник, Отказ) Экспорт

	Если Источник.ОбменДанными.Загрузка Тогда
	
		Возврат;
	
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
	               |	ПапкиЭлектронныхПисем.Ссылка
	               |ИЗ
	               |	Справочник.ПапкиЭлектронныхПисем КАК ПапкиЭлектронныхПисем
	               |ГДЕ
	               |	ПапкиЭлектронныхПисем.ПредопределеннаяПапка
	               |	И ПапкиЭлектронныхПисем.Владелец = &УчетнаяЗапись";
	
	Запрос.УстановитьПараметр("УчетнаяЗапись",Источник.Ссылка);
	
	Результат = Запрос.Выполнить();
	Если Результат.Пустой() Тогда
		УправлениеЭлектроннойПочтой.СоздатьПредопределенныеПапкиЭлектронныхПисемДляУчетнойЗаписи(Источник.Ссылка);
	КонецЕсли;

КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ВладельцыУчетныхЗаписейЭлектроннойПочты (БСП)

ПроверитьВозможностьОтправкиИПолученияЭлектроннойПочты (БСП)

ДоступныеУчетныеЗаписи (БСП)

ПерейтиКДокументацииПоВводуУчетнойЗаписиЭлектроннойПочты (БСП)

СоздатьПредопределенныеПапкиЭлектронныхПисемДляУчетнойЗаписи (БСП)

ПолучитьДоступныеУчетныеЗаписиДляОтправки (БСП)

ЗарегистрироватьУчетныеЗаписиЭлектроннойПочтыКОбработкеДляПереходаНаНовуюВерсию (БСП)

TurboConf - расширение Конфигуратора 1С