КолонкаМакета (БСП)

Автор: 1С
ОбщийМодуль.ЗагрузкаДанныхИзФайлаКлиентСервер
БСП

Колонка макета. Возвращает колонку макета по имени.

// Возвращает колонку макета по имени.
//
// Параметры:
//  Имя				 - Строка - Имя колонки.
//  СписокКолонок	 - Массив - Набор колонок макета.
// 
// Возвращаемое значение:
//  Структура - Структура с описание колонки. Состав структуры см. в функции ОписаниеКолонкиМакета.
//              Если колонка не найдена, то Неопределено.
//
Функция КолонкаМакета(Имя, СписокКолонок) Экспорт
	Для каждого Колонка Из  СписокКолонок Цикл
		Если Колонка.Имя = Имя Тогда
			Возврат Колонка;
		КонецЕсли;
	КонецЦикла;
	
	Возврат Неопределено;
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УдалитьКолонкуМакета (БСП)

ОписаниеКолонкиМакета (БСП)

Подставить свой макет в СКД

Странное поведение макета в СКД

ТекстыМакетов (БСП)

МакетыРазличаются (БСП)

КолонкиДляЗагрузкиДанных (БСП)

КолонкиИмеютГруппировку (БСП)

Добавить или обновить колонку

TurboConf - расширение Конфигуратора 1С