УдалитьКолонкуМакета (БСП)

Автор: 1С
ОбщийМодуль.ЗагрузкаДанныхИзФайлаКлиентСервер
БСП

Удалить колонку макета. Удаляет колонку макета из массива.

// Удаляет колонку макета из массива.
//
// Параметры:
//  Имя				 - Строка - Имя колонки.
//  СписокКолонок	 - Массив - Набор колонок макета.
//
Процедура УдалитьКолонкуМакета(Имя, СписокКолонок) Экспорт
	
	Для Индекс = 0 По СписокКолонок.Количество() -1  Цикл
		Если СписокКолонок[Индекс].Имя = Имя Тогда
			СписокКолонок.Удалить(Индекс);
			Возврат;
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

КолонкаМакета (БСП)

ОписаниеКолонкиМакета (БСП)

Удалить дубли строк в таблице значений

Подставить свой макет в СКД

Странное поведение макета в СКД

ТекстыМакетов (БСП)

МакетыРазличаются (БСП)

КолонкиДляЗагрузкиДанных (БСП)

КолонкиИмеютГруппировку (БСП)

TurboConf - расширение Конфигуратора 1С