УстановитьСтатусИзмененияПометкиУдаления (БСП)

Автор: 1С
ОбщийМодуль.ЗаметкиПользователяСлужебный
БСП

Установить статус изменения пометки удаления. Добавляет признак изменения пометки удаления объекта.

// Добавляет признак изменения пометки удаления объекта.
Процедура УстановитьСтатусИзмененияПометкиУдаления(Источник) Экспорт
	
	Если Источник.ОбменДанными.Загрузка Тогда
		Возврат;
	КонецЕсли;
	
	Если Не Источник.ПометкаУдаления Тогда
		ПометкаУдаленияПоСсылке = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Источник.Ссылка, "ПометкаУдаления");
		Если ПометкаУдаленияПоСсылке = Истина Тогда
			Источник.ДополнительныеСвойства.Вставить("СнятаПометкаУдаления");
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

УстановитьСтатусИзмененияПометкиУдаленияДокумента (БСП)

УстановитьСтатусИзмененияПометкиУдаленияОбъекта (БСП)

УстановитьСнятьПометкуУдаленияЗаметок (БСП)

ОтработатьПризнакИзмененияПометкиУдаленияПриЗаписиПисьма (БСП)

УстановитьПометкуУдаленияЗадач (БСП)

УстановитьПометкуУдаленияУВложенийПисьма (БСП)

УстановитьПапкуДляМассиваПисем (БСП)

УстановитьПометкуУдаленияФайловДокументовПередЗаписью (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз