РазрешитьРедактированиеРеквизитовОбъектаПослеПроверкиСсылок (БСП)

Автор: 1С
ОбщийМодуль.ЗапретРедактированияРеквизитовОбъектовСлужебныйКлиент
БСП

Разрешить редактирование реквизитов объекта после проверки ссылок.

Процедура РазрешитьРедактированиеРеквизитовОбъектаПослеПроверкиСсылок(Результат, Параметры) Экспорт
	
	Если Результат Тогда
		ЗапретРедактированияРеквизитовОбъектовКлиент.УстановитьРазрешенностьРедактированияРеквизитов(
			Параметры.Форма, Параметры.ЗаблокированныеРеквизиты);
		
		ЗапретРедактированияРеквизитовОбъектовКлиент.УстановитьДоступностьЭлементовФормы(Параметры.Форма);
	КонецЕсли;
	
	Если Параметры.ОбработкаПродолжения <> Неопределено Тогда
		ВыполнитьОбработкуОповещения(Параметры.ОбработкаПродолжения, Результат);
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

РазрешитьРедактированиеРеквизитовОбъектаПослеПредупреждения (БСП)

РазрешитьРедактированиеРеквизитовОбъекта (БСП)

ЗапретРедактированияПредусмотрен (БСП)

ПроверитьСсылкиНаОбъектПослеПодтвержденияРедактирования (БСП)

ЗакончитьРедактированиеСРасширениемПослеПроверкиЗашифрован (БСП)

ЗакончитьРедактированиеСРасширениемПослеПроверкиЗашифрованПовтор (БСП)

ПроверитьСсылкиНаОбъект (БСП)

ПриДобавленииИсключенийПоискаСсылок (БСП)

ПриВыбореРеквизитовОбъекта (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз