ИменаИзмеренийРегистраПоТипу (БСП)

Автор: 1С
ОбщийМодуль.ЗащитаПерсональныхДанных
БСП

Имена измерений регистра по типу.

Функция ИменаИзмеренийРегистраПоТипу(МетаданныеРегистра, Тип) Экспорт
	
	ИменаИзмерений = Новый Массив;
	
	Для Каждого Измерение Из МетаданныеРегистра.Измерения Цикл
		
		Если Измерение.Тип.СодержитТип(Тип) Тогда
			ИменаИзмерений.Добавить(Измерение.Имя);
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат ИменаИзмерений;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

Групповое изменение Измерения в НабореЗаписей регистра сведений

ВыбратьИзмеренияНезависимогоРегистраСведенийДляОбработки (БСП)

СоздатьВременнуюТаблицуЗначенийЗаблокированныхИзмерений (БСП)

ЭтоПолноеИмяРегистраСведений (БСП)

ЭтоПолноеИмяРегистраНакопления (БСП)

ЭтоПолноеИмяРегистраБухгалтерии (БСП)

ЭтоПолноеИмяРегистраРасчета (БСП)

ЭтоПолноеИмяРегистра (БСП)

СоздатьВременнуюТаблицуИзмеренийНезависимогоРегистраСведенийДляОбработки (БСП)

TurboConf - расширение Конфигуратора 1С