ИменаРеквизитовПоТипу (БСП)

Автор: 1С
ОбщийМодуль.ЗащитаПерсональныхДанных
БСП

Имена реквизитов по типу.

Функция ИменаРеквизитовПоТипу(МетаданныеОбъекта, Тип) Экспорт
	
	ИменаРеквизитов = Новый Массив;
	
	Для Каждого Реквизит Из МетаданныеОбъекта.Реквизиты Цикл
		Если Реквизит.Тип.СодержитТип(Тип) Тогда
			ИменаРеквизитов.Добавить(Реквизит.Имя);
		КонецЕсли;
	КонецЦикла;
	
	Возврат ИменаРеквизитов;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИменаРеквизитовТЧОбъектаПоТипу (БСП)

ИмяРеквизитаОрганизация (БСП)

ИмяУзлаОбщихРеквизитов (БСП)

Реквизиты (БСП)

ИменаРеквизитовИсточникаСодержащихСубъект (БСП)

ИменаИзмеренийРегистраПоТипу (БСП)

ИмяОбъектаМетаданных (БСП)

ИмяКаналаПоТипуСообщения (БСП)

TurboConf - расширение Конфигуратора 1С