ИменаРеквизитовТЧОбъектаПоТипу (БСП)

Автор: 1С
ОбщийМодуль.ЗащитаПерсональныхДанных
БСП

Имена реквизитов объекта по типу.

Функция ИменаРеквизитовТЧОбъектаПоТипу(МетаданныеОбъекта, ИмяТабличнойЧасти, Тип, Полные = Ложь) Экспорт
	
	ИменаРеквизитов = Новый Массив;
	МетаданныеТЧ = МетаданныеОбъекта.ТабличныеЧасти.Найти(ИмяТабличнойЧасти);
	
	Если МетаданныеТЧ <> Неопределено Тогда
		
		Для Каждого Реквизит Из МетаданныеТЧ.Реквизиты Цикл
			
			Если Реквизит.Тип.СодержитТип(Тип) Тогда
				
				Если Полные Тогда
					ИменаРеквизитов.Добавить(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку("%1.%2", ИмяТабличнойЧасти, Реквизит.Имя));
				Иначе
					ИменаРеквизитов.Добавить(Реквизит.Имя);
				КонецЕсли;
				
			КонецЕсли;
			
		КонецЦикла;
		
	КонецЕсли;
	
	Возврат ИменаРеквизитов;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИменаРеквизитовПоТипу (БСП)

ИмяОбъектаМетаданных (БСП)

ВидОбъектаПоТипу (БСП)

ИменаРеквизитовИсточникаСодержащихСубъект (БСП)

ПолноеИмяОбъектаМетаданных (БСП)

Реквизиты Объекта в Структуру

ПолучитьЗначениеРеквизитаПредмета (БСП)

ИмяБазовогоТипаПоОбъектуМетаданных (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз