ПропуститьРегистрациюОбъекта (БСП)

Автор: 1С
ОбщийМодуль.ЗащитаПерсональныхДанных
БСП

Пропустить регистрацию объекта. Проверяет необходимость регистрации объекта на узлах плана обмена.

// Проверяет необходимость регистрации объекта на узлах плана обмена.
//
// Параметры:
//	ИмяПланаОбмена	- Строка - имя плана обмена, для которого будет выполнен механизм регистрации.
//	Объект 			- СправочникОбъект, ДокументОбъект, РегистрСведенийНаборЗаписей и т.п. - проверяемый объект.
//
Функция ПропуститьРегистрациюОбъекта(ИмяПланаОбмена, Объект) Экспорт
	
	Если Не ИспользоватьСкрытиеПерсональныхДанныхСубъектов() Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ОбменДанными") Тогда
		
		МодульОбменДаннымиПовтИсп = ОбщегоНазначения.ОбщийМодуль("ОбменДаннымиПовтИсп");
		Если МодульОбменДаннымиПовтИсп.ЭтоПланОбменаРаспределеннойИнформационнойБазы(ИмяПланаОбмена) Тогда
			Возврат Ложь;
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат ЭтоОбъектСоСкрытымиПерсональнымиДанными(Объект);
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПравилаРегистрацииОбъекта (БСП)

РеквизитыОбъектаДляРегистрации (БСП)

ПропуститьПроверкуЗапретаИзменения (БСП)

ИнициализацияТаблицыПравилРегистрацииОбъектов (БСП)

ПравилаРегистрацииОбъектовПланаОбмена (БСП)

ПравилаРегистрацииОбъектов (БСП)

ПолучитьПравилаРегистрацииОбъектов (БСП)

ВыполнитьПравилаРегистрацииДляОбъекта (БСП)

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз