СкрытиеПерсональныхДанныхСубъектов (БСП)

Автор: 1С
ОбщийМодуль.ЗащитаПерсональныхДанных
БСП

Скрытие персональных данных субъектов. Обработчик регламентного задания СкрытиеПерсональныхДанных.

// Обработчик регламентного задания СкрытиеПерсональныхДанных.
Процедура СкрытиеПерсональныхДанныхСубъектов() Экспорт
	
	ОбщегоНазначения.ПриНачалеВыполненияРегламентногоЗадания(Метаданные.РегламентныеЗадания.СкрытиеПерсональныхДанныхСубъектов);
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("ПустаяДата", '00010101');
	Запрос.УстановитьПараметр("ТекущаяДата", НачалоДня(ТекущаяДатаСеанса()));
	
	Запрос.Текст = "ВЫБРАТЬ
	|	СубъектыДляСкрытия.Субъект КАК Субъект,
	|	ТИПЗНАЧЕНИЯ(СубъектыДляСкрытия.Субъект) КАК ТипСубъекта
	|ИЗ
	|	РегистрСведений.СубъектыДляСкрытияПерсональныхДанных КАК СубъектыДляСкрытия
	|ГДЕ
	|	СубъектыДляСкрытия.ДатаСкрытия <= &ТекущаяДата
	|	И СубъектыДляСкрытия.ДатаСкрытия > &ПустаяДата
	|	И СубъектыДляСкрытия.Состояние = ЗНАЧЕНИЕ(Перечисление.СостоянияСубъектовДляСкрытия.ГотовКСкрытию)
	|ИТОГИ ПО
	|	ТипСубъекта";
	
	ВыборкаТипов = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	
	Пока ВыборкаТипов.Следующий() Цикл
		
		Субъекты = Новый Массив;
		ВыборкаСубъектов = ВыборкаТипов.Выбрать();
		
		Пока ВыборкаСубъектов.Следующий() Цикл
			Субъекты.Добавить(ВыборкаСубъектов.Субъект);
		КонецЦикла;
		
		СкрытьПерсональныеДанныеСубъектов(Субъекты);
		
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ИспользоватьСкрытиеПерсональныхДанныхСубъектов (БСП)

ДнейДоСкрытияПерсональныхДанныхСубъектов (БСП)

СкрытьПерсональныеДанныеСубъектов (БСП)

ОбновитьДатыСкрытияПерсональныхДанныхСубъектов (БСП)

ПередСкрытиемПерсональныхДанныхСубъектов (БСП)

ЭтоОбъектСоСкрытымиПерсональнымиДанными (БСП)

ИзменитьНастройкиСкрытияПерсональныхДанных (БСП)

ПолучениеСубъектовДляСкрытияПерсональныхДанных (БСП)

TurboConf - расширение Конфигуратора 1С