ПоместитьДанныеВоВременноеХранилище (БСП)

Автор: 1С
ОбщийМодуль.ЖурналРегистрации
БСП

Поместить данные во временное хранилище. Только для внутреннего использования.

// Только для внутреннего использования.
//
Процедура ПоместитьДанныеВоВременноеХранилище(СобытияЖурнала, УникальныйИдентификатор) Экспорт
	
	Для Каждого СтрокаСобытие Из СобытияЖурнала Цикл
		Если ПустаяСтрока(СтрокаСобытие.АдресДанных) Тогда
			АдресДанных = "";
		Иначе
			ЧтениеXML = Новый ЧтениеXML();
			ЧтениеXML.УстановитьСтроку(СтрокаСобытие.АдресДанных);
			АдресДанных = СериализаторXDTO.ПрочитатьXML(ЧтениеXML);
		КонецЕсли;
		СтрокаСобытие.АдресДанных = ПоместитьВоВременноеХранилище(АдресДанных, УникальныйИдентификатор);
	КонецЦикла;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////

Рекомендации

Похожие публикации

ПоместитьВХранилище (БСП)

ПоместитьМанифестКонфигурацииВоВременноеХранилище (БСП)

ПоместитьФайлыВоВременноеХранилище (БСП)

ВыгрузитьТекущуюОбластьДанныхВоВременноеХранилище (БСП)

ПоместитьФайлВХранилище (БСП)

ДанныеПоСертификату (БСП)

ИзвлечьТекст (БСП)

ОписаниеПередаваемогоФайла (БСП)

ПоместитьФайлВХранилищеМенеджераСервиса (БСП)

TurboConf - расширение Конфигуратора 1С