СброситьЗначениеРеквизитаУпорядочивания

Автор: 1С
ОбщийМодуль.НастройкаПорядкаЭлементов
БСП

Обнуляет значение реквизита дополнительного упорядочивания у объекта.

// Обнуляет значение реквизита дополнительного упорядочивания у объекта.
//
// Параметры:
//  Источник          - Объект - объект, создаваемый копированием;
//  ОбъектКопирования - Ссылка - исходный объект, который является источником копирования.
Процедура СброситьЗначениеРеквизитаУпорядочивания(Источник, ОбъектКопирования) Экспорт
	
	Если СтандартныеПодсистемыСервер.ЭтоИдентификаторОбъектаМетаданных(Источник) Тогда
		Возврат;
	КонецЕсли;
	
	Информация = ПолучитьИнформациюДляПеремещения(Источник.Ссылка.Метаданные());
	Если УОбъектаЕстьРеквизитДопУпорядочивания(Источник, Информация) Тогда
		Источник.РеквизитДопУпорядочивания = 0;
	КонецЕсли;
	
КонецПроцедуры

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////
FastCode - сервис для программистов 1С

Похожие публикации

ЗаполнитьЗначениеРеквизитаУпорядочивания (БСП)

ПолучитьНовоеЗначениеРеквизитаДопУпорядочивания (БСП)

СброситьКэшМеханизмаРегистрацииОбъектов (БСП)

СброситьЗначениеКонстантыСИзменениямиДляПодчиненногоУзлаРИБСФильтрами (БСП)

ЛокализованныеЗначенияРеквизитов (БСП)