ТелоСодержитТипизированноеСообщение

Автор: 1С
ОбщийМодуль.СообщенияВМоделиСервиса
БСП

Для внутреннего использования.

// Для внутреннего использования.
//
Функция ТелоСодержитТипизированноеСообщение(Знач НетипизированноеТело, Сообщение) Экспорт
	
	Если ТипЗнч(НетипизированноеТело) <> Тип("Строка") Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если Не СтрНачинаетсяС(НетипизированноеТело, "<") ИЛИ Не СтрЗаканчиваетсяНа(НетипизированноеТело, ">") Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Попытка
		Чтение = Новый ЧтениеXML;
		Чтение.УстановитьСтроку(НетипизированноеТело);
		
		Сообщение = ФабрикаXDTO.ПрочитатьXML(Чтение);
		
		Чтение.Закрыть();
		
	Исключение
		Возврат Ложь;
	КонецПопытки;
	
	Возврат Сообщение.Тип() = СообщенияВМоделиСервисаПовтИсп.ТипСообщение();
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////
FastCode - сервис для программистов 1С

Похожие публикации

ПрочитатьСообщениеИзНетипизированногоТела (БСП)

ЗаписатьСообщениеВНетипизированноеТело (БСП)

ТипТело (БСП)

ТипТелоОбласти (БСП)

ТипАутентифицированноеТелоОбласти (БСП)