ПреобразоватьДвоичныеДанныеВBase64

Автор: 1С
ОбщийМодуль.ЭлектроннаяПодписьВМоделиСервиса
БСП
Функция ПреобразоватьДвоичныеДанныеВBase64(Свойство, Значение, ДополнительныеПараметры, Отказ) Экспорт
	
	Если ТипЗнч(Значение) = Тип("ДвоичныеДанные") Тогда
		Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура")
			И ДополнительныеПараметры.Свойство("ЗаменятьДвоичныеДанные")
			И ДополнительныеПараметры.ЗаменятьДвоичныеДанные Тогда
			Возврат Значение.Размер();
		Иначе
			Возврат Base64Строка(Значение);
		КонецЕсли;
	КонецЕсли;
		
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////
FastCode - бесплатный сервис для программистов 1С

Похожие публикации

ПреобразоватьBase64ВДвоичныеДанные (БСП)

ДвоичныеДанныеВBase64ПриНеобходимости (БСП)

ТекстВДвоичныхДанных (БСП)

ДвоичныеДанныеФайла (БСП)

ДанныеФайлаИДвоичныеДанные (БСП)