НастройкиАвтоматическогоОбновления

Автор: 1С
ОбщийМодуль.ПолучениеОбновленийПрограммы
БСП
Функция НастройкиАвтоматическогоОбновления() Экспорт
	
	Результат = НовыйНастройкиАвтоматическогоОбновления();
	Настройки = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить(
		"ИнтеррнетПоддержка",
		"ПолучениеОбновленийПрограммы");
	Если ТипЗнч(Настройки) = Тип("Структура") Тогда
		ЗаполнитьЗначенияСвойств(Результат, Настройки);
		Если Настройки.Свойство("СпособАвтоматическойПроверки") Тогда
			Результат.РежимАвтоматическойПроверкиНаличияОбновленийПрограммы = Настройки.СпособАвтоматическойПроверки;
		КонецЕсли;
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

///////////////////////////////////////////////////////////////////////////////////////////////////////
// Copyright (c) 2019, ООО 1С-Софт
// Все права защищены. Эта программа и сопроводительные материалы предоставляются 
// в соответствии с условиями лицензии Attribution 4.0 International (CC BY 4.0)
// Текст лицензии доступен по ссылке:
// https://creativecommons.org/licenses/by/4.0/legalcode
///////////////////////////////////////////////////////////////////////////////////////////////////////
OneTracker - трекер учета рабочего времени программиста 1С

Похожие публикации

НастройкиОбновления (БСП)

ЗаписатьНастройкиАвтоматическогоОбновления (БСП)

СохранитьИнформациюОДоступномОбновленииВНастройках (БСП)

ДоступноИспользованиеОбновленияПрограммы (БСП)

ЗаписатьНастройкиОбновления (БСП)