Раскрасить даты календаря

3 ROXy

Процкдура раскрашивает даты в календаре

календарь дата
Процедура ПроизводственныйКалендарьПриВыводеПериода(Элемент, ОформлениеПериода)
	Попытка 
		МассивДат = ПоискДатВРегистреСведениийДатыКурсов ();
		Для Каждого ДатаПериода Из ОформлениеПериода.Даты Цикл
			Если МассивДат.Найти(ДатаПериода.Дата) <> Неопределено Тогда
				ДатаПериода.ЦветФона = webЦвета.БледноЗеленый;
			КонецЕсли;
			Если ДеньНедели(ДатаПериода.Дата)>=6 Тогда
				ДатаПериода.ЦветТекста = webЦвета.Красный; 
			КонецЕсли;
		КонецЦикла;
	Исключение
	КонецПопытки;
КонецПроцедуры
Назад к списку

Похожие шаблоны

Прибавить рабочие дни к дате

Прибавить к дате день

Получить разницу дат в [секундах, минутах, днях, ...]

Конвертация даты из формата ISO8601 в дату 1С с учетом миллисекунд

описание даты в таблице значений

Дата создания ссылки

Получить дату через указанное количество [дней, месяцев, лет, ...]

Как по GUID определить время и дату создания ссылки?

Запрет выгрузки в КД по дате запрета редактирования

Комментарии

FastCode - сервис поиска кода 1С

Уже более 1000 разработчиков используют FastCode в работе!