Устанавливаем заголовок системы

2 Добавил: miha

        // Устанавливаем заголовок системы 
        ЗаголовокСистемы = ПолучитьЗаголовокСистемы();
        Если Не ОсновнаяОрганизация.Пустая() Тогда
            Попытка
                ЗаголовокСистемы = ЗаголовокСистемы + " / " + СокрЛП(ОсновнаяОрганизация.Наименование);
            Исключение
            КонецПопытки;
        КонецЕсли;
        Если ПараметрыСеанса.ИспользованиеРИБ Тогда
            Если НЕ ПустаяСтрока(ПланыОбмена.Полный.ЭтотУзел().Наименование) Тогда
                ЗаголовокСистемы = ЗаголовокСистемы + " / " + СокрЛП(ПланыОбмена.Полный.ЭтотУзел());
            Иначе
                ЗаголовокСистемы = ЗаголовокСистемы + " / " + СокрЛП(ПланыОбмена.ПоОрганизации.ЭтотУзел());
            КонецЕсли;
        КонецЕсли;
        ЗаголовокСистемы = ЗаголовокСистемы + " / "+ СокрЛП(глТекущийПользователь);
        УстановитьЗаголовокСистемы(ЗаголовокСистемы);
Назад к списку

Комментарии

FastCode - сервис поиска кода 1С

Уже более 1000 разработчиков используют FastCode в работе!