Структура метаданных регистра сведений

Добавил: prog1c

Возвращает структуру метаданных регистра сведений. В параметр функции можно передать строковое название регистра, или объект РегистрСведений, МенеджерЗаписи, НаборЗаписей

Функция СтруктураМетаданныхРегистраСведений(РегистрСведений) Экспорт
	
	СтруктураРегистра         = Неопределено;
	РегистрСведенийМетаданные = Неопределено;
	
	Если ТипЗнч(РегистрСведений) = Тип("Строка") Тогда
		РегистрСведенийМетаданные = Метаданные.НайтиПоПолномуИмени("РегистрСведений." + РегистрСведений);
	Иначе
		
		РегистрСведенийМетаданные = Метаданные.НайтиПоТипу(ТипЗнч(РегистрСведений));
		Если РегистрСведенийМетаданные <> Неопределено Тогда
			РегистрСведенийМетаданные = Метаданные.НайтиПоПолномуИмени("РегистрСведений." + РегистрСведенийМетаданные.Имя);
		КонецЕсли;
		
	КонецЕсли;
	
	Если РегистрСведенийМетаданные <> Неопределено Тогда
		
		НаименованиеРегистра       = РегистрСведенийМетаданные.Имя;
		МетаданныеРегистраСведений = Метаданные.РегистрыСведений[НаименованиеРегистра];

		МассивИзмерений = Новый Массив;
		Для Каждого Измерение Из МетаданныеРегистраСведений.Измерения Цикл
			МассивИзмерений.Добавить(Измерение.Имя);
		КонецЦикла;
		
		МассивРесурсов  = Новый Массив;
		Для Каждого Ресурс Из МетаданныеРегистраСведений.Ресурсы Цикл
			МассивРесурсов.Добавить(Ресурс.Имя);
		КонецЦикла;
		
		СтруктураРегистра = Новый Структура;
		СтруктураРегистра.Вставить("Измерения", МассивИзмерений);
		СтруктураРегистра.Вставить("Ресурсы",   МассивРесурсов);
		
	КонецЕсли;
	
	Возврат СтруктураРегистра;
	
КонецФункции // СтруктураМетаданныхРегистраСведений()
Назад к списку

Комментарии

FastCode - сервис поиска кода 1С

Уже более 1000 разработчиков используют FastCode в работе!