Колонки в строку

1 prog1c

Возвращает строку с названиями колонок коллекции (ТаблицаЗначений, РезультатЗапроса)

Функция КолонкиВСтроку(Коллекция, Разделитель=",")

	СтрКоллекция = "";
	
	Для каждого Колонка Из Коллекция.Колонки Цикл
		Если Не ПустаяСтрока(СтрКоллекция) Тогда
			СтрКоллекция = СтрКоллекция + Разделитель;
		КонецЕсли;
		СтрКоллекция = СтрКоллекция + Колонка.Имя;
	КонецЦикла;
	
	Возврат СтрКоллекция;

КонецФункции // КолонкиВСтроку()
Назад к списку

Похожие шаблоны

Удалить дубли строк в таблице значений

ДобавитьИтераторТаблице

Выделенные строки

ПрочитатьXMLВТаблицу

Разложить строку в массив

Запрос с нумерацией строк

Поиск кириллицы в строке

Описание строки в таблице значений

часть строки

Комментарии

FastCode - сервис поиска кода 1С

Уже более 1000 разработчиков используют FastCode в работе!