УдалитьСтрокиТаблицыЗначений

3 prog1c

Удаляет строки ТЗ, соответсвующие структуре отбора

Таблица значений ТаблицаЗначений
Функция УдалитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивСтрок Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // УдалитьСтрокиТаблицыЗначений()
Назад к списку

Похожие шаблоны

Удалить дубли строк в таблице значений

Описание строки в таблице значений

ОбъединитьТаблицыЗначений

Отбор по таблице значений

ОставитьСтрокиТаблицыЗначений

Удаление строк таблицы по условию

Чтение файлов Excel в таблицу значений (автоматическое наименование столбцов)

Таблица значений из списка колонок

Сохранение таблицы значений в XML

Комментарии

FastCode - сервис поиска кода 1С

Уже более 1000 разработчиков используют FastCode в работе!