ОставитьСтрокиТаблицыЗначений

1 Добавил: prog1c

Оставляет строки ТаблицыЗначений, соответсвующие структуре отбора (удаляет не соответсвующие)

ТаблицаЗначений Таблица значений
Функция ОставитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	МассивУдаления = Новый Массив;
	Для Каждого СтрокаТЗ Из Таблица Цикл
		Если МассивСтрок.Найти(СтрокаТЗ) = Неопределено Тогда
			МассивУдаления.Добавить(СтрокаТЗ);
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивУдаления Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // ОставитьСтрокиТаблицыЗначений()
Назад к списку

Комментарии

FastCode - сервис поиска кода 1С

Уже более 1000 разработчиков используют FastCode в работе!