ОставитьСтрокиТаблицыЗначений

3 prog1c 29 6

Оставляет строки ТаблицыЗначений, соответсвующие структуре отбора (удаляет не соответсвующие)

Функция ОставитьСтрокиТаблицыЗначений(Знач Таблица, СтруктураОтбора) Экспорт
	
	МассивСтрок = Новый Массив;
	РезультатОтбора = Таблица.НайтиСтроки(СтруктураОтбора);
	Для каждого СтрокаОтбора Из РезультатОтбора Цикл
		МассивСтрок.Добавить(СтрокаОтбора);
	КонецЦикла;
	
	МассивУдаления = Новый Массив;
	Для Каждого СтрокаТЗ Из Таблица Цикл
		Если МассивСтрок.Найти(СтрокаТЗ) = Неопределено Тогда
			МассивУдаления.Добавить(СтрокаТЗ);
		КонецЕсли;
	КонецЦикла;
	
	Для Каждого СтрокаТЗ Из МассивУдаления Цикл
		Таблица.Удалить(СтрокаТЗ);
	КонецЦикла;
	
    Возврат Таблица;
    
КонецФункции // ОставитьСтрокиТаблицыЗначений()
TurboConf - расширение Конфигуратора 1С

Похожие публикации

Описание строки в таблице значений

УдалитьСтрокиТаблицыЗначений

ОбъединитьТаблицыЗначений

Отбор по таблице значений

Удаление строк таблицы по условию