Прямой эфир

СергейТ добавил комментарий к публикации Выбор каталога (папки) файловой системы

(1) Калинин Михаил, А в чем преимущество?
Про ваш вариант знаю, но чаще пользуюсь таким. А когда реально асинх нужно, тогда использую таки Ждать, а не вот это вот всё с кучей процедур ))).
Не, такое тоже использую, но это должно быть прям обоснованно.


Калинин Михаил добавил комментарий к публикации Выбор каталога (папки) файловой системы

Лучше использовать асинхронный вариант, как здесь https://fastcode.im/Templates/7673/vybor-fajla-upravlyaemoe-prilozhenie.
Только заменить РежимДиалогаВыбораФайла.Открытие на РежимДиалогаВыбораФайла.ВыборКаталога


bolsun добавил комментарий к публикации Как зарегистрироваться в ChatGPT из России

Протестировать, что все работает можно через Postman.
Тип запроса: POST
Адрес: https://api.openai.com/v1/completions
В Headers добавляем заголовки
Content-Type application/json
Authorization Bearer <Ваш API-Key>
В Body вставляем Json
{
model: text-...


МВЮ добавил комментарий к публикации Обмен с помощью Web - Сервисов. Новый (С примерами)

что за ужасный код выложили...


RomanVG добавил комментарий к публикации Общая форма для вывода сообщений пользователю в HTML

Аналог такой формы есть в УПП, - в обработке ДокументооборотСКонтролирующимиОрганами есть форма ПросмотрHTML.
Пример ее использования:
Содержимое = h1Сообщение с тегами HTML/h1;
ФормаПросмотраHTML = Обработки.ДокументооборотСКонтролирующимиОрганами.Получ...


Катерина добавил комментарий к публикации Как разработчику 1С получать пассивный доход, а не головную боль?

(1) NoDrama, Ну как вам сказать о разнице?) В Маркете42 мы предоставляем разработки только по модели SaaS. Клиент с нами, пока платит за аренду 1С и, соответственно, обработку тоже оплачивает. Т.е. на Инфостарте вы продали отчет ну за 1-2 стартмани и все, ...


bolsun добавил комментарий к публикации Запрос к нейросети ChatGPT

Пример запроса и ответа


buketoff добавил комментарий к публикации Подключение к базе через COM соединение и создание нового документа

(5) Razlagutt, Время идет вперед и давно уже надо перейти полностью, например, на http вместо com


NoDrama добавил комментарий к публикации Как выделить слово внутри ячейки макета жирным шрифтом (курсивным)?

НаСервере
Функция ВывестиТабДокНаСервере()
ТабДок=Новый ТабличныйДокумент;
Макет = РеквизитФормыВЗначение(Объект).ПолучитьМакет(Макет);
Область=Макет.ПолучитьОбласть(Шапка);
Область.Параметры.Текст=Демонстрация части текста +СделатьЖирным(жирным)+ в т...


NoDrama добавил комментарий к публикации Как разработчику 1С получать пассивный доход, а не головную боль?

В чем принципиальная разница с Инфостартом ?? кроме того, что у них на сайте больше доработок разработок и больше пользователей.
точно так же можно продавать и тд


Дмитрий Кондратьев добавил комментарий к публикации Unicode decode

Чуть более короткая функция UnicodeEncode.
Функция UnicodeEncode(Строка)
ЧтениеJSON = Новый ЧтениеJSON;
ЧтениеJSON.УстановитьСтроку( + Строка + );
Возврат ПрочитатьJSON(ЧтениеJSON)
КонецФункции
(Объект ЧтениеJSON есть начиная с версии 8.3.6.)


Дмитрий Кондратьев добавил комментарий к публикации Unicode decode

Ещё чуть более короткая функция перевода числа из 16'теричной системы в 10'теричную.
Функция ПереводЧислаИз16в10(Знач Число16)
Возврат ЧислоИзШестнадцатеричнойСтроки(0x + Число16)
КонецФункции
Есть платформенная функция ЧислоИзШестнадцатеричнойСтр...


Little Friend добавил комментарий к публикации Unicode decode

Чуть более короткая функция перевода числа из 16'тиричной системы в 10'тиричную.
Функция ПереводЧислаИз16в10(Знач Число16)
Цифры16 = 0123456789ABCDEF;
Результат = 0;
Для Сч = 1 По СтрДлина(Число16) Цикл
Цифра10 = СтрНайти(Цифры16, Сред(Число16...


Little Friend добавил комментарий к публикации Копирование файлов

Процедура СкопироватьФайлы(Знач Источник, Знач Приемник)
КаталогПриемник = Новый Файл(Приемник);
Если Не КаталогПриемник.Существует() Тогда
СоздатьКаталог(КаталогПриемник.ПолноеИмя);
КонецЕсли;

Файлы = НайтиФайлы(Источник, *.*, Ложь);
Для каждого ...


Little Friend добавил комментарий к публикации Копирование файлов

Т.е., если файл без расширения, то вместо его копирования, будет создан одноимённый каталог? А если каталог имеет расширение (да, каталоги тоже могут иметь расширение), то вместо создания каталога, будет выполнено копирование.
Может условие
Если ПустаяСтро...


MichaPot добавил комментарий к публикации Пример формирования внешней печатной формы из макета Word. БСП

(6) ilgobe, Такая же проблема. Почему-то все внешние обработки открывают вордовский документ, а три из них не открывают. Хотя код верный


Gedortanka добавил комментарий к публикации История пользователя не обновляется, при программном добавлении события

Как вариант, сразу после добавления события в историю работы, вызывать метод
ОбновитьИнтерфейс();


СергейТ добавил комментарий к публикации Добавляем подменю со статусами в командную панель

Хорошо бы скрин ))


ilgobe добавил комментарий к публикации Пример формирования внешней печатной формы из макета Word. БСП

Код отрабатывает без ошибок, но по окончанию не открывает вордовский документ. Что нужно ещё дополнительно прописать?


СергейТ добавил комментарий к публикации Получить нужные поля элемента справочника в виде структуры

(3) vlhown, Можно, можно ))
Но я писал в конфу без БСП и сложности все запихивать не хотел. Вот и родилась простенькая простенькая функция. А то в ней понаписана куча всяких получений объектов или обращений к реквизитам через точку, решил переделать всё по...