Публикации

БСП
Разработки

Добавить кнопку на форму в командную панель

Добавление кнопки в панель управления формы
СергейТ 4 1
Процедура ДобавитьКнопкуНаФормуВПанель(Форма) Экспорт
	НоваяКоманда		=Форма.Команды.Добавить("ФормаКоманднаяПанель_КомандаМояКоманда");
	НоваяКоманда.Действие="Подключаемый_ВыполнитьКоманду";
	
	Кнопка				=Форма.Элементы.Добавить("МояКнопка", Тип("КнопкаФормы"), Форма.Элементы.ФормаКоманднаяПанель);
	Кнопка.Заголовок	="Заголовок кнопки";
	Кнопка.ИмяКоманды	="ФормаКоманднаяПанель_КомандаМояКоманда";
КонецПроцедуры

Интерактивный отбор дерева значений

В связи с тем, что у дерева значений на форме, нет интерактивного отбора, реализовываем свой отбор Постановка задачи: На управляемой форме имеем дерево значений, необходимо дать пользователю возможно производить отбор строк Решение, теория: Так как, соз...
markers 14 3

OneTracker - трекер учета рабочего времени программиста 1С Промо

Программа автоматически замеряет время работы разработчика с 1С в режиме Конфигуратора или Предприятия. Учет ведется в разрезах задач, информационных баз или объектов конфигураций.
990 руб.

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

Для передачи таблицы значений с сервера на клиент нельзя использовать объект типа таблица значений. Нужно преобразовывать таблицу в массив структур. Функция для преобразования Таблицы значений (ТаблицаЗначений) в массив структур.
СергейТ 4 1
&НаСервереБезКонтекста
Функция ТаблицуЗначенийВМассив(ТаблЗнач)
	Результат=Новый Массив;
	Для Каждого ТекСтр Из ТаблЗнач Цикл
		СтруктураСтроки=Новый Структура;
		Для Каждого ТекКол Из ТаблЗнач.Колонки Цикл
			СтруктураСтроки.Вставить(ТекКол.Имя,ТекСтр[ТекКол.Имя])
		КонецЦикла;
		Результат.Добавить(СтруктураСтроки)
	КонецЦикла;
	Возврат Результат
КонецФункции

ДеревоЗначений вывод на управляемую форму

Вручную на форме ничего не надо создавать
&НаСервере
Процедура ВывестиДзНаФорму(ДеревоОбъект)
	
	// Создание Реквизита формы типа ДанныеФормыДерево
	МассивДобавляемыхРеквизитов = Новый Массив;
	МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Дерево", 
	Новый ОписаниеТипов("ДеревоЗначений")));
	Для Каждого Колонка Из ДеревоОбъект.Колонки Цикл
		МассивДобавляемыхРеквизитов.Добавить(
		Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "Дерево"));
	КонецЦикла;
	ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);
	
	
	// Преобразование объекта прикладного типа ДеревоЗначений 
	// в реквизит управляемой формы (данные формы)
	ЗначениеВРеквизитФормы(ДеревоОбъект, "Дерево");
	
	
	// Создание элемента формы типа ТаблицаФормы для отображения дерева
	ЭлементДерево = Элементы.Добавить("Дерево", Тип("ТаблицаФормы"));
	ЭлементДерево.ПутьКДанным = "Дерево";
	ЭлементДерево.Отображение = ОтображениеТаблицы.Дерево;
	
	
	Для Каждого Колонка Из ДеревоОбъект.Колонки Цикл
		НовыйЭлемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), 
		ЭлементДерево);
		НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
		НовыйЭлемент.ПутьКДанным = "Дерево." + Колонка.Имя;
	КонецЦикла;
	
	
КонецПроцедуры

Программное добавление нового пользователя

Программное добавление нового пользователя в базу, в которой используется стандартная подсистема "Пользователи" БСП.
Iyad1020 6 1
Процедура СоздатьНовогоПользователя(Имя, Пароль)
    
    ПроверкаНаСуществующегоПользователя = ПользователиИнформационнойБазы.НайтиПоИмени(Имя);
    
    Если ПроверкаНаСуществующегоПользователя = Неопределено Тогда
        
        ОписаниеПользователяИБ = Пользователи.НовоеОписаниеПользователяИБ();
        
        //В списке выбора не показываем
        ОписаниеПользователяИБ.ПоказыватьВСпискеВыбора = Ложь;
        
        ОписаниеПользователяИБ.АутентификацияСтандартная = Истина;            
        
        ОписаниеПользователяИБ.Вставить("Действие", "Записать");
        ОписаниеПользователяИБ.Имя = Имя;
        ОписаниеПользователяИБ.Пароль = Пароль;
        
        
        НовыйПользователь = Справочники.Пользователи.СоздатьЭлемент();
        НовыйПользователь.Имя    = Имя;
        НовыйПользователь.Код             = Имя;
        НовыйПользователь.Недействителен  = ложь;
        
        НовыйПользователь.ДополнительныеСвойства.Вставить(
            "ОписаниеПользователяИБ", ОписаниеПользователяИБ);
        
        Попытка
            НовыйПользователь.Записать();            
            ДобавитьРолиНовомуПользователю(НовыйПользователь.Имя);
       	Исключение
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Ошибка создания нового пользователя" + ОписаниеОшибки());
        КонецПопытки;
        
    КонецЕсли;
        
    
КонецПроцедуры

Процедура ДобавитьРолиНовомуПользователю(Имя);
    Пользователь = ПользователиИнформационнойБазы.НайтиПоИмени(Имя);
    Пользователь.Роли.Добавить(Метаданные.Роли.АдминистраторСистемы);
    Пользователь.Роли.Добавить(Метаданные.Роли.ПолныеПрава);
    Пользователь.Записать();
КонецПроцедуры

Чтение Excel через Табличный документ

chugindanil 13 1
//На клиенте

ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогВыбора.Заголовок = "Выберите файл";

Если ДиалогВыбора.Выбрать() Тогда
	ИмяФайла = ДиалогВыбора.ПолноеИмяФайла; 
	Команда1НаСервере(ИмяФайла);
	
КонецЕсли; 


//На сервере

//Вывод в табличный документ

ТабличныйДокумент = Новый ТабличныйДокумент;

ТабличныйДокумент.Прочитать(ИмяФайла, СпособЧтенияЗначенийТабличногоДокумента.Значение);

//вывод в таблицу значений

ПЗ = Новый ПостроительЗапроса;

ПЗ.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТабличныйДокумент.Область());

ПЗ.ДобавлениеПредставлений = ТипДобавленияПредставлений.НеДобавлять;

ПЗ.ЗаполнитьНастройки();

ПЗ.Выполнить();

ТаблицаЗначений = ПЗ.Результат.Выгрузить();

Выгрузка запроса в XML. Выгрузка объекта

chugindanil 13 1
&НаСервере
Процедура КомандаВыполнитьНаСервере()
	
	ИмяФайла = "d:\test.xml";
	
	Запрос = Новый Запрос("ВЫБРАТЬ
	| Номенклатура.Код КАК Код,
	| Номенклатура.Наименование КАК Наименование,
	| Номенклатура.Артикул КАК Артикул,
	| Номенклатура.Ссылка КАК Номенклатура
	|ИЗ
	| Справочник.Номенклатура КАК Номенклатура
	|ГДЕ
	| Номенклатура.ЭтоГруппа = ЛОЖЬ");
	
	ЗаписьXML = Новый ЗаписьXML;
	ЗаписьXML.ОткрытьФайл(ИмяФайла,"UTF-8");
	
	ВыборкаРезультата = Запрос.Выполнить().Выгрузить(); 
	ЗаписьXML.ЗаписатьНачалоЭлемента("Номенклатура");
	Для каждого Выборка Из ВыборкаРезультата Цикл
		ЗаписатьXML(ЗаписьXML, Выборка.Номенклатура.ПолучитьОбъект());           
	КонецЦикла;
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ЗаписьXML.Закрыть();
	
КонецПроцедуры

Проверка заполненности сложных объектов

Проверяет, содержит ли переменная или коллекция какие-либо данные
Функция СодержитДанные(ЗначениеДляПроверки) Экспорт
	Результат = Ложь;
	
	Если ЗначениеДляПроверки <> Неопределено Тогда
		Если ТипЗнч(ЗначениеДляПроверки) = Тип("ТаблицаЗначений")
			Или ТипЗнч(ЗначениеДляПроверки) = Тип("Массив") 
			Или ТипЗнч(ЗначениеДляПроверки) = Тип("СписокЗначений") 
			Тогда
			
			Если ЗначениеДляПроверки.Количество() > 0 Тогда
				Результат = Истина;
			КонецЕсли;
			
		Иначе
			Результат = ЗначениеЗаполнено(ЗначениеДляПроверки);
		КонецЕсли
		
	КонецЕсли;
	
	Возврат Результат;
КонецФункции 

Создать объект ОписаниеТипов

Автор: HostHost

FastCode 51 7
НоваяКолонка = ТЗ.Колонки.Добавить("КолонкаДата", ОбщегоНазначения.ОписаниеТипаДата(ЧастиДаты.Дата));

НоваяКолонка = ТЗ.Колонки.Добавить("КолонкаЧисло", ОбщегоНазначения.ОписаниеТипаЧисло(12));

НоваяКолонка = ТЗ.Колонки.Добавить("КолонкаСтрока", ОбщегоНазначения.ОписаниеТипаСтрока(100));

НоваяКолонка = ТЗ.Колонки.Добавить("КолонкаСсылка", ОбщегоНазначения.ОписаниеТипаВсеСсылки());

HTTP в 1С для начинающих. Курс

Закрой все вопросы по работе с HTTP в 1C за одно занятие!
FastCode 51 7
-10%

Открытие формы выбора с отбором

Приведен пример открытия формы выбора с отбором по контрагенту и по периоду, как для управляемых форм так и для обычных. Для открытия форм следует применять метод глобального контекста ОткрытьФорму (при использовании версии платформы 1С:Предприятие 8.2 ...
Razlagutt 5 1

Интеграция 1С и Битрикс 24 через расширения. Курс

Разработка модуля интеграции ведется полностью в расширении, что позволит вам добавлять его даже в 1С:Fresh.
FastCode 51 7
-10%

1С мобильное приложение B2B. Видео курс по разработке

Интенсив по разработке мобильного приложения 1С, для внутри корпоративного использования. Разработка обмена, динамического интерфейса, авторизации, XDTO. В процессе изучения вы создадите мобильное приложение 1С для B2B с нуля до 100%.
FastCode 51 7
-10%

Разработка HTML интерфейса мобильного приложения 1С. Курс

Разработай красивое мобильное приложение 1С с помощью HTML и CSS
FastCode 51 7
-10%

Чат бот ВКонтакте на 1С. Курс

Интенсив по разработке чат бота ВКонтакте. Используя API ВКонтакте создавать чат бот ВКонтакте из 1С. Получить список пользователей группы ВКонтакте и разослать им сообщения.
FastCode 51 7
Бесплатно

1С XDTO для начинающих. Курс

Закрой все вопросы по XDTO за одно занятие!
FastCode 51 7
-10%

Преобразовать строку таблицы значений в структуру

Автор: HostHost

FastCode 51 7
ПараметрыСтроки = ОбщегоНазначения.СтрокаТаблицыЗначенийВСтруктуру(ТаблицаПоказателей[0]);

Значения реквизитов, прочитанных из информационной базы для нескольких объектов

Автор: HostHost

FastCode 51 7
ВидыРасчета = Новый Массив;

Для Каждого СтрокаИсточника Из ТаблицаВычислений Цикл

        ВидыРасчета.Добавить(СтрокаИсточника.ВидНачисления);

КонецЦикла;

ВидыРасчетаИнфо = ОбщегоНазначения.ЗначенияРеквизитовОбъектов(ВидыРасчета, "УчетВремениВЧасах,КатегорияНачисленияИлиНеоплаченногоВремени,ТребуетсяРасчетБазы");

Строковые функции. Альтернатива для СтрРазделить, СтрНайти и т.д.

В старых версиях конфигураций можно получить сообщение о том, что, например, СтрРазделить не найден. Тогда в качестве альтернативы стоит использовать ОбщийМодуль → СтроковыеФункцииКлиентСервер, где собраны необходимые функции по работе со строкой. Например...
Razlagutt 5 1

Формирование файла CSV с записью в файл на клиенте

buketoff 20 4

&НаКлиенте
Процедура СформироватьCsvФайл(Команда)
	
	ПутьККаталогу = ОткрытьДиалогВыбораФайла();
	Текст = ВыгрузитьВCSV(ПутьККаталогу.ПолноеИмяФайла);
	
	Кодировка = КодировкаТекста.ANSI;
	ТекстовыйФайлЗапись = Новый ЗаписьТекста(ПутьККаталогу.ПолноеИмяФайла,Кодировка);
	ТекстовыйФайлЗапись.ЗаписатьСтроку(Текст);
	ТекстовыйФайлЗапись.Закрыть();
	
КонецПроцедуры

&НаКлиенте
Функция ОткрытьДиалогВыбораФайла(НачальныйКаталог = Неопределено, МножественныйВыбор = Ложь, Фильтр = Неопределено) экспорт
	СтандартнаяОбработка = Ложь;
	ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
	ДиалогОткрытияФайла.Расширение = "csv";
	Фильтр = "csv|*.csv";
	ДиалогОткрытияФайла.Фильтр = Фильтр;
	ДиалогОткрытияФайла.Каталог    = НачальныйКаталог;
	ДиалогОткрытияФайла.Заголовок  = "Выберите каталог...";
	ДиалогОткрытияФайла.МножественныйВыбор          = Ложь;
	ДиалогОткрытияФайла.ПроверятьСуществованиеФайла = Истина;
	ДиалогОткрытияФайла.ПредварительныйПросмотр     = Истина;
	
	Если Не ДиалогОткрытияФайла.Выбрать() Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	Возврат ДиалогОткрытияФайла;
	
КонецФункции

Функция ВыгрузитьВCSV(имяФайлаCSV);
	Текст = СоздатьДанныеCSV(ТаблицаДокументов,Разделитель);
	Возврат Текст;
КонецФункции

Функция СоздатьДанныеCSV(ТаблицаДокументов, Разделитель)
	Текст = "";
	Для Каждого Запись из ТаблицаДокументов Цикл
		Если Текст = "" тогда
			Текст = СоздатьЗаголовкиCSV(ТаблицаДокументов, Разделитель) + Символы.ПС;   	
		КонецЕсли;  
		Текст = Текст + Запись.snils + Разделитель + Запись.surname
		+ Разделитель + Запись.name + Разделитель + Запись.patronymic + Разделитель 
		+ Запись.oid + Разделитель + Запись.compaignId + Разделитель + Формат(Запись.dateOfBirth, "ДЛФ=Д") + Разделитель + Запись.citizenship + Разделитель 
		+ Запись.specialty + Разделитель + Запись.financingType + Разделитель + Запись.applicationDate + Разделитель + Запись.targetReception 
		+ Разделитель + Запись.testResultType + Разделитель + Запись.testResultOrganization + Разделитель + Запись.testResultYear + Символы.ПС;         	
	КонецЦикла;
	Возврат Текст;
КонецФункции

// Создаем строку загоовков для CSV-файла
Функция СоздатьЗаголовкиCSV(ТаблицаДокументов, Разделитель)
	НоваяТаблица = ТаблицаДокументов.Выгрузить();
	КолонкиТЗ = НоваяТаблица.Колонки;
	Для каждого Колонка Из КолонкиТЗ Цикл  
		СтрКолонки = "" + СтрКолонки + Колонка.Имя + Разделитель;
	КонецЦикла; 
	Возврат СтрКолонки;
КонецФункции