Публикации

БСП
Разработки

Найдено результатов: 56


Начисления

Автор: HostHost

FastCode 37 5
// 1.

СотрудникиДаты = тзТаблица.Скопировать(, "Объект, Период");

СотрудникиДаты.Колонки.Объект.Имя = "Сотрудник";

ТекущиеДанныеОплатыТруда = ПлановыеНачисленияСотрудников.ТекущиеДанныеОплатыТрудаСотрудников(Параметры.Объект.Ссылка, СотрудникиДаты);

// 2.

ДанныеНачислений = ЗарплатаКадрыРасширенный.ДействующиеНачисленияСотрудников(СотрудникиДаты, Параметры.Объект.Ссылка);

Стажи сотрудников

Получить стажи сотрудников в ЗУП 3
&НаСервере
Функция РассчитатьСтажиСотрудниковЗанявшихПозиции(ПозицияШР, Должность, Подразделение, ДатаОтсчета, КатегорияДолжности, ОкладИндекс)
	
	СтруктураДанных = Новый Структура();
	
	СтруктураДанных.Вставить("ДатаНачала",);
	СтруктураДанных.Вставить("ДатаОкончания",);
	СтруктураДанных.Вставить("РазмерОклада",);
	
	ПараметрыПолучения = ПолучитьПараметры();
	ПараметрыПолучения.Организация = Отчет.Организация;
	
	//Если ЗначениеЗаполнено(Подразделение) Тогда
	//	ПараметрыПолучения.Подразделение = Подразделение;	
	//КонецЕсли;
	
	//Если ВключаяУволенныхНаНачалоПериода Тогда
	//	ПараметрыПолучения.ВключаяУволенныхНаНачалоПериода = Истина;
	//КонецЕсли;
	
	ПараметрыПолучения.НачалоПериода = НачалоМесяца(ДатаОтсчета);
	ПараметрыПолучения.ОкончаниеПериода = КонецМесяца(ДатаОтсчета);
	ПараметрыПолучения.ПодработкиРаботниковПоТрудовымДоговорам = Истина;
	ПараметрыПолучения.РаботникиПоДоговорамГПХ = Ложь;
	
	//ЗарплатаКадрыОбщиеНаборыДанных.ДобавитьВКоллекциюОтбор(
	//ПараметрыПолучения.Отборы, "ДолжностьПоШтатномуРасписанию", "=", ПозицияШР);
	
	ЗарплатаКадрыОбщиеНаборыДанных.ДобавитьВКоллекциюОтбор(
	ПараметрыПолучения.Отборы, "Должность", "=", Должность);
	
	ЗарплатаКадрыОбщиеНаборыДанных.ДобавитьВКоллекциюОтбор(
	ПараметрыПолучения.Отборы, "Подразделение", "=", Подразделение);
	
	ПараметрыПолучения.КадровыеДанные = "Сотрудник,ФизическоеЛицо,Подразделение,Должность,ДолжностьПоШтатномуРасписанию,КоличествоСтавок,ВидЗанятости,ДатаПриема,ДатаУвольнения";
	
	ТаблицаСотрудников = КадровыйУчет.СотрудникиОрганизации(Истина, ПараметрыПолучения);
	
	//ДанныеПозиции = УправлениеШтатнымРасписанием.ДанныеПозицииШтатногоРасписания(ПозицияШР, ДатаОтсчета, Истина);
	
	ТаблицаСтажей = КадровыйУчетРасширенный.СведенияОСтажахСотрудников(ТаблицаСотрудников);
	
	Возврат ТаблицаСтажей;
	
КонецФункции

Сведения об организации

Получить сведения об организации в ЗУП 3
&НаСервере
Процедура СведенияОбОрганизацииНаСервере()
	
	//Без передачи списка показателей возвращаются все доступные значения показатели
	//Если нужно значение конкретного показателя см. подробнее ЗарплатаКадрыБазовый.ПолучитьСведенияОбОрганизации 
	
	СведенияОбОрганизации = ЗарплатаКадрыБазовый.ПолучитьСведенияОбОрганизации(Объект.Организация,ТекущаяДата(), );
		
КонецПроцедуры

Ответственные организации

Получить ответственных организации в ЗУП 3
ЗапрашиваемыеЗначения = Новый Структура;
	ЗапрашиваемыеЗначения.Вставить("Организация", Объект.Документ.Организация);
	
	ЗапрашиваемыеЗначения.Вставить("Руководитель");
	ЗапрашиваемыеЗначения.Вставить("ДолжностьРуководителя");
	
	ЗапрашиваемыеЗначения.Вставить("ГлавныйБухгалтер");
	
	ЗапрашиваемыеЗначения.Вставить("РуководительКадровойСлужбы");
	ЗапрашиваемыеЗначения.Вставить("ДолжностьРуководителяКадровойСлужбы");
	
	ДатаВЗапросОтветственных = Объект.Документ.Дата;
	
	//!!! ПОЗВОЛЯЕТ ПОЛУЧИТЬ ДАННЫЕ ТОЛЬКО НА ДАТУ СЕАНСА
	ЗарплатаКадры.ПолучитьЗначенияПоУмолчанию(ЗапрашиваемыеЗначения, ДатаВЗапросОтветственных);
	
	ФИОГлБух = "";
	
	Если ФизическиеЛицаЗарплатаКадры.Просклонять(ЗапрашиваемыеЗначения.ГлавныйБухгалтер.Наименование, 3, ФИОГлБух, 
		?(ЗапрашиваемыеЗначения.ГлавныйБухгалтер.Пол = Перечисления.ПолФизическогоЛица.Мужской, 1, 2)) Тогда	
		
		//Область3.Параметры.ФИОГлБух = ФИОГлБух;

	КонецЕсли;	
	
	ОбластьМакетаПриказ.Параметры.ФИОГлавныйБухгалтер					= ФизическиеЛицаЗарплатаКадрыКлиентСервер.ФамилияИнициалы(ФИОГлБух);
	ОбластьПодписиРуководитель.Параметры.ФИО 								= ФизическиеЛицаЗарплатаКадры.РасшифровкаПодписи(ЗапрашиваемыеЗначения.Руководитель);
	ОбластьПодписиРуководитель.Параметры.Должность 						= ЗапрашиваемыеЗначения.ДолжностьРуководителя;


	//ОТВЕТСТВЕННЫЕ ЛИЦА НА ЗАДАННУЮ ДАТУ

	ДатаВЗапросОтветственных = ДАТА(2019,09,02);
		
	ЗапрашиваемыеЗначения = СведенияОбОтветственныхЛицах.СведенияОбОтветственныхЛицах(Выборка.Организация, "Руководитель,ДолжностьРуководителя", ДатаВЗапросОтветственных);

Склонение ФИО

Просклонять ФИО в ЗУП 3
РезультатСклонения = "";

Если ФизическиеЛицаЗарплатаКадры.Просклонять(Строка(Руководитель), 3, РезультатСклонения, Руководитель.Пол) Тогда
					Шапка.Параметры.ФИОРуководителя = РезультатСклонения
КонецЕсли;

Открытие дополнительной формы

Автор: HostHost

FastCode 37 5
СотрудникиКлиент.ОткрытьДополнительнуюФорму(

СотрудникиКлиентСервер.ОписаниеДополнительнойФормы("Справочник.МедицинскиеСтраховыеПолисы.Форма.ФормаПолисыПоСотруднику"), ЭтотОбъект);

Выполнить копирование документа

Автор: HostHost

FastCode 37 5
ИсправлениеДокументовЗарплатаКадры.СкопироватьДокумент(Приемник, Источник, ИсключаемыеСвойства = "", ИсключаемыеТабличныеЧасти = "", ДанныеЗаполнения = Неопределено) Экспорт;

Кадровые данные сотрудника

Получить кадровые данные сотрудника в ЗУП 3
КадровыеДанныеСотрудников = КадровыйУчет.КадровыеДанныеСотрудников(Истина, 
    ОбщегоНазначенияКлиентСервер.ЗначениеВМассиве(Строка), 
    "Организация,ФизическоеЛицо,ТабельныйНомер,Подразделение,Должность,ВидЗанятости,ДолжностьПоШтатномуРасписанию,КоличествоСтавок,ДатаПриема,ДатаУвольнения,ГрафикРаботы,СтатьяФинансирования, РазрядКатегория ", ТекущаяДата());

// Список всех возможных кадровых данных
//
// ФИОПолные
// Пол
// ТабельныйНомер
// Организация
// Подразделение
// Должность
// ДатаПриема
// ДатаУвольнения
// Возраст
// Фамилия
// Имя
// Отчество
// Наименование
// ФизическоеЛицоНаименование
// Код
// ФизическоеЛицоКод
// АдресДляИнформирования
// АдресДляИнформированияПредставление
// АдресЗаПределамиРФ
// АдресЗаПределамиРФПредставление
// АдресМестаПроживания
// АдресМестаПроживанияПредставление
// АдресПоПрописке
// АдресПоПропискеПредставление
// ТелефонДомашний
// ТелефонДомашнийПредставление
// ТелефонРабочий
// ТелефонРабочийПредставление
// EMail
// EMailПредставление
// ДокументПериодРегистрации
// ДокументВид
// ДокументКодМВД
// ДокументСерия
// ДокументНомер
// ДокументДатаВыдачи
// ДокументСрокДействия
// ДокументКемВыдан
// ДокументКодПодразделения
// ДокументПредставление
// ИнвалидностьПериодРегистрации
// Инвалидность
// ИнвалидностьДатаВыдачи
// ИнвалидностьСрокДействияСправки
// ГражданствоПериодРегистрации
// Страна
// ИННВСтранеГражданства
// ПроцентСевернойНадбавки
// ТекущаяОрганизация
// ТекущееПодразделение
// ТекущаяДолжность
// ТекущийВидЗанятости
// ОсновноеРабочееМестоВОрганизации
// ДатаПриема
// ДатаЗавершенияРаботы
// ОформленПоТрудовомуДоговору
// ДатаУвольнения
// ТекущаяТарифнаяСтавка
// ТекущийСпособРасчетаАванса
// ТекущийАванс
// ДатаНачалаУчета
// ПриказОПриеме
// ПриказОПриемеДата
// ПриказОПриемеНомер
// НазначениеПодработки
// ПриказОбУвольнении
// ПриказОбУвольненииДата
// ПриказОбУвольненииНомер
// ПриказОбУвольненииСтатьяТКРФ
// ПрекращениеПодработки
// РабочееМестоПериодРегистрации
// РабочееМестоРегистратор
// ВидСобытия
// КоличествоСтавок
// ЭтоГоловнойСотрудник
// УчетЗатратПериодРегистрации
// СпособОтраженияЗарплатыВБухучете
// ОтношениеКЕНВД
// СтатьяФинансирования
// УчетЗатратДокументОснование
// ОплатаТрудаПериодЗаписи
// ОплатаТрудаРегистратор
// ТарифнаяСтавка
// ФОТ
// Надбавка
// ВидЗанятостиПериодЗаписи
// ВидЗанятостиРегистратор
// ВидЗанятости
// АвансПериодЗаписи
// АвансРегистратор
// СпособРасчетаАванса
// Аванс
// КлассУсловийТрудаПериодРегистрации
// КлассУсловийТруда
// КлассУсловийТрудаДатаРегистрацииИзменений
// ЗарплатныйПроектПериодРегистрации
// ЗарплатныйПроектРегистратор
// ЗарплатныйПроект
// НомерЛицевогоСчета.

Инициалы фамилия

Получить инициалы фамилию (ИО Фамилия) в ЗУП 3
ДанныеПечати.ФИОРуководителяСокращенное = ФизическиеЛицаЗарплатаКадры.РасшифровкаПодписи(ДанныеФИО);

Фамилия инициалы

Получить фамилию инициалы (Фамилия ИО) в ЗУП 3
ДанныеПечати.ФИОРуководителяСокращенное = ФизическиеЛицаЗарплатаКадрыКлиентСервер.ФамилияИнициалы(ДанныеДляПечатиСотрудники.ФизическоеЛицо)