Публикации

БСП
Разработки

Найдено результатов: 62


Сгибы листка (задача с собеседования)

Функция возвращает строку, в которой 0 - сгиб от нас, 1 - к нам. Первый параметр - необходимое число сложений, второй и третий параметры служебные. Всего в записи функции 77 символов. Не по-русски потому, что так короче. function W(k,a=0,b=0)return?(k1,,W(... Читать дальше
FastCode 37 5

Генератор вариантов формул

В данной задаче требуется сформировать список строк, каждая из которых будет являться вариантом формулы, содержащей аргументы X1, X2, ..., Xmax, знаки арифметических операций и скобки. Этот список затем можно использовать для решений задач типа "расставьте... Читать дальше
FastCode 37 5

Объединение непересекающихся интервалов в запросе

Задача заключается в том, чтобы собрать в один непрерывный интервал все время проживание гостя в гостинице, если между интервалами не было перерывов. То есть для таблицы t1.png Это делает следующий запрос, являющийся развитием идей решения задачи 14 из пре... Читать дальше
FastCode 37 5

Количество дней, когда товар был на складе

Обычный подход к решению этой задачи - рассчитать "остатки на каждый день" и подсчитать дни наличия товара. Предлагается другой подход: найти все интервалы отсутствия товара и вычесть их общую длину из длины периода. Получается следующий запрос: ВЫБРАТЬ ... Читать дальше
FastCode 37 5

Загадка суммы и произведения

Пусть x и y два целых числа 1 < = x < = y притом x + y < = 100. Салли сказали только сумму x + y, а вот Полю произведение xy. Салли и Пол честнейшие ребята, это всем известно, они и друг другу отродясь не врали. И вот такой вышел у них разговор: Пол: «Не ... Читать дальше
FastCode 37 5

Первый пропущенный артикул

Чтобы по максимуму использовать номерную емкость, иногда требуется назначать новому элементу незанятую комбинацию цифр, а для этого определять первый пропущенный артикул. Идея решения здесь в том, чтобы преобразовать артикулы в числа методом из статьи "Выр... Читать дальше
FastCode 37 5

Подсчет записей, содержащих одинаковые неупорядоченные пары значений

Если в некоторой таблице есть два поля, заполняемые в произвольном порядке, то как посчитать число "одинаковых" записей? К примеру, для таблицы "два любимых блюда" t2.png так можно посчитать число различных комбинаций блюд: t3.png Собственно, запрос, решаю... Читать дальше
FastCode 37 5

Выбрать в запросе одну запись из нескольких

Имеется таблица, содержащая, например, колонки Ф, К1, К2, К3, К4. Для каждого значения Ф в таблице может быть несколько записей. t4.png Требуется получить таблицу, включающую по одной (любой) записи для каждого значения Ф. t5.png Несмотря на простоту форм... Читать дальше
FastCode 37 5

Квайн (программа, распечатывающая свой собственный текст)

Автор: ildarovich

FastCode 37 5
С="С="";Л=Лев(С,3);П=Сред(С,3);Сообщить(Л+Л+П+П)";Л=Лев(С,3);П=Сред(С,3);Сообщить(Л+Л+П+П)
Процедура КВН(К)С="Процедура КВН(К)С="";Л=Лев(С,19);П=Сред(С,19);Сообщить(Л+Л+П+П)КонецПроцедуры";Л=Лев(С,19);П=Сред(С,19);Сообщить(Л+Л+П+П)КонецПроцедуры

Свернуть строки в таблице значений конкатенацией

Автор: ildarovich

FastCode 37 5
Дано.Сортировать("Поле1, Поле2");
ё = Дано.Количество();
Пока ё > 1 Цикл
   ё = ё - 1;
    Если Дано[ё - 1].Поле1 = Дано[ё].Поле1 И Дано[ё - 1].Поле2 = Дано[ё].Поле2 Тогда
        Дано[ё - 1].Поле3 = Дано[ё - 1].Поле3 + Дано[ё].Поле3;
        Дано.Удалить(ё)
    КонецЕсли 
КонецЦикла;