Публикации

БСП
Разработки

Найдено публикаций: 6


Документ Регистратор При Проверке Записи

Получить ссылку на объект записи для которого нужно проверять исключение из правил Используется когда нужно для какого-то вида документа сделать особую проверку на запрет изменения данных При проведении документа с исключением инициируются так же изменен...

Заполнить параметры запроса из структуры

Кусок кода с заполнением параметров запроса из структуры с именами полей равных именам параметров. Позволяет заполнять запроса с неизвестным составом параметров из структуры, где добавлены все возможные параметры
СергейТ 9 1
//пПараметрыЗапроса - структура с данными для запроса
ПараметрыЗапроса=Запрос.НайтиПараметры();
Для Каждого ПараметрЗапроса Из пПараметрыЗапроса Цикл
	Если ПараметрыЗапроса.Найти(ПараметрЗапроса.Ключ)<>Неопределено Тогда
		Запрос.УстановитьПараметр(ПараметрЗапроса.Ключ, ПараметрЗапроса.Значение)
	КонецЕсли
КонецЦикла;

Реквизиты Объекта в Структуру

Вернуть реквизиты объекта в виде структуры Ключ (Имя) - Значение
СергейТ 9 1
&НаСервере
Функция РеквизитыОбъектаВСтруктуру()
	Результат=Новый Структура;
	ДанныеОбъекта=РеквизитФормыВЗначение("Объект");
	МДОбъекта=ДанныеОбъекта.Метаданные();
	Для Каждого ТекРеквизит Из МДОбъекта.Реквизиты Цикл
		Результат.Вставить(ТекРеквизит.Имя,ДанныеОбъекта[ТекРеквизит.Имя])
	КонецЦикла;
	Возврат Результат
КонецФункции

Добавить кнопку на форму в командную панель

Добавление кнопки в панель управления формы
СергейТ 9 1
Процедура ДобавитьКнопкуНаФормуВПанель(Форма) Экспорт
	НоваяКоманда		=Форма.Команды.Добавить("ФормаКоманднаяПанель_КомандаМояКоманда");
	НоваяКоманда.Действие="Подключаемый_ВыполнитьКоманду";
	
	Кнопка				=Форма.Элементы.Добавить("МояКнопка", Тип("КнопкаФормы"), Форма.Элементы.ФормаКоманднаяПанель);
	Кнопка.Заголовок	="Заголовок кнопки";
	Кнопка.ИмяКоманды	="ФормаКоманднаяПанель_КомандаМояКоманда";
КонецПроцедуры

Выгрузить Таблицу значений в массив структур (для передачи сервер - клиент)

Для передачи таблицы значений с сервера на клиент нельзя использовать объект типа таблица значений. Нужно преобразовывать таблицу в массив структур. Функция для преобразования Таблицы значений (ТаблицаЗначений) в массив структур.
СергейТ 9 1
&НаСервереБезКонтекста
Функция ТаблицуЗначенийВМассив(ТаблЗнач)
	Результат=Новый Массив;
	Для Каждого ТекСтр Из ТаблЗнач Цикл
		СтруктураСтроки=Новый Структура;
		Для Каждого ТекКол Из ТаблЗнач.Колонки Цикл
			СтруктураСтроки.Вставить(ТекКол.Имя,ТекСтр[ТекКол.Имя])
		КонецЦикла;
		Результат.Добавить(СтруктураСтроки)
	КонецЦикла;
	Возврат Результат
КонецФункции