Публикации

БСП
Разработки

Найдено публикаций: 2

Jratdroid 33 1 1

Произношение текста голосом

произносит заданную фразу
Jratdroid 33 1 1
Voice = Новый COMObject("SAPI.SpVoice");
Voice.Speak("Привет!");

Задать вопрос

Вопрос и обработка ответа без синхронных методов (не модально)
Jratdroid 33 1 1
&НаКлиенте
Процедура ДиалогСВопросом(Команда)
     Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса", ЭтотОбъект);	
     ПоказатьВопрос(Оповещение,  "Текст вопроса",  
        РежимДиалогаВопрос.ДаНетОтмена,
        0, // таймаут в секундах
        КодВозвратаДиалога.Да, // кнопка по умолчанию
        "Заголовок" 
    );    
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеЗакрытияВопроса(Результат, Параметры) Экспорт
     Если Результат = КодВозвратаДиалога.Да Тогда
        Сообщить("Ответ Да!");
    КонецЕсли;	
 КонецПроцедуры