Jratdroid


Произношение текста голосом

произносит заданную фразу
Диалог Сообщить Голос Звук
10 Добавил: Jratdroid
Voice = Новый COMObject("SAPI.SpVoice");
Voice.Speak("Привет!");

Задать вопрос

Вопрос и обработка ответа без синхронных методов (не модально)
Вопрос Оповещение Диалог Немодально
5 Добавил: Jratdroid
&НаКлиенте
Процедура ДиалогСВопросом(Команда)
     Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса", ЭтотОбъект);	
     ПоказатьВопрос(Оповещение,  "Текст вопроса",  
        РежимДиалогаВопрос.ДаНетОтмена,
        0, // таймаут в секундах
        КодВозвратаДиалога.Да, // кнопка по умолчанию
        "Заголовок" 
    );    
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеЗакрытияВопроса(Результат, Параметры) Экспорт
     Если Результат = КодВозвратаДиалога.Да Тогда
        Сообщить("Ответ Да!");
    КонецЕсли;	
 КонецПроцедуры