Публикации

БСП
Разработки

Найдено публикаций: 11

bolsun 30 4

СКД. Повторение шапки отчета на каждой странице

Как вывести шапку отчёта на каждой странице средствами СКД? То есть не формируя отчёт программно. О программных решениях есть достаточно информации, но хочется знать как это сделать самим компоновщиком. Отвечал на подобный вопрос на Инфостарте, настройки к... Читать дальше
1 bolsun 30 4

Клиент TurboStore

Программа добавляет в Конфигуратор "ТурбоПоиск", который ищет сразу по нескольким источникам данных: сервису FastCode, библиотеке стандартных подсистем (БСП) и каталогу разработок TurboStore.
bolsun 30 4

OneTracker - трекер учета рабочего времени программиста 1С

Программа автоматически замеряет время работы разработчика с 1С в режиме Конфигуратора или Предприятия. Учет ведется в разрезах задач, информационных баз или объектов конфигураций.
bolsun 30 4

OneScript

OpenSource инструмент автоматизации для специалистов по 1С. Проект является независимой кросс-платформенной реализацией виртуальной машины, исполняющей скрипты на языке 1С:Предприятие.
6 bolsun 30 4

УТ11 Счет на оплату из реализации

Печать из реализации, без типовых ограничений, номер и дата из документа реализации
1 bolsun 30 4

Обновлятор-1С: групповое (пакетное) обновление и обслуживание всех баз за один раз

Быстрое и надежное обновление файловых и серверных баз, защита от шифровальщиков, автоматическое обновление доработанных конфигураций и расширений, а также многое другое.
1 bolsun 30 4

Нетленка 1С - защита конфигураций

Защита конфигураций и обработок 1С 8.3
bolsun 30 4

Записать текст в файл

2 bolsun 30 4
&НаКлиенте
Процедура ЗаписатьТекстовыйФайл(ИмяФайла, Текст)
	
	ТекстовыйФайл = Новый ТекстовыйДокумент;
 
    ТекстовыйФайл.УстановитьТекст(Текст);
	
	//ТекстовыйФайл.ДобавитьСтроку(""); 
    
    ТекстовыйФайл.Записать(ИмяФайла,
        КодировкаТекста.UTF8
    );
	
КонецПроцедуры

Прочитать текст из файла

1 bolsun 30 4
&НаКлиенте
Функция ПрочитатьТекстовыйФайл(ИмяФайла)
	
	ТекстовыйФайл = Новый ТекстовыйДокумент;
 
    ТекстовыйФайл.Прочитать(ИмяФайла,
        КодировкаТекста.UTF8
    );
	
	Возврат ТекстовыйФайл.ПолучитьТекст();
	
КонецФункции

Запустить внешнее приложение

Выполняет запуск внешнего процесса, с оповещением и ожиданием результата
УФ
6 bolsun 30 4
&НаКлиенте
Процедура КомандаВыполнитьПрограмму(Команда)
	
	СтрокаЗапуска = "C:\Application.exe";
	
	НачатьЗапускПриложения(Новый ОписаниеОповещения("НачатьЗапускПриложенияЗавершение", ЭтотОбъект), СтрокаЗапуска,, Истина);
	
КонецПроцедуры  

&НаКлиенте
Процедура НачатьЗапускПриложенияЗавершение(КодВозврата, ДополнительныеПараметры) Экспорт 
    
    //Вставить обработку завершения выполнения
    
КонецПроцедуры