Публикации

БСП
Разработки

Найдено публикаций: 2

pkonev 1

Оформление (раскраска) строки табличной части обычной формы по условию, при получении данных

Событие ПриПолученииДанных используется для оформления ячеек строк данных, отображаемых табличным полем. В нем можно оформить или раскрасить строку, в зависимости от данных.
pkonev 1
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
		
	Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
			
		Если ОформлениеСтроки.ДанныеСтроки.Товар.Уценен Тогда
			ОформлениеСтроки.Ячейки.Комментарий.УстановитьТекст("Уценка");
			ОформлениеСтроки.Ячейки.Комментарий.ЦветФона = Новый Цвет(255, 255, 128);
			ОформлениеСтроки.Ячейки.Комментарий.ЦветТекста = Новый Цвет(0, 0, 0);
			ОформлениеСтроки.Ячейки.Комментарий.ТолькоПросмотр = Истина;
		КонецЕсли;
				
		//ОформлениеСтроки.ЦветФона = Новый Цвет(255, 255, 128);
		//ОформлениеСтроки.ЦветТекста = Новый Цвет(0, 0, 0);
						
	КонецЦикла;
	
КонецПроцедуры

Пример работы с OpenOffice/LibreOffice Calc

Нужно загрузить прайс поставщика в xls, но возможности использовать Excel нет. Кто-нибудь загружал данные через OpenOffice или LibreOffice, можете скинуть рабочий пример, откуда начать копать? Нужно загрузить прайс поставщика в xls, но возможности испо...
pkonev 1